某企業様からのご依頼です。社内のPCがインターネットにつながらない、LAN内のNASにもアクセスできないとのこと。
実は少し前から一部のPCが同じ症状になる、しかも問題の起こるPCが一定しない、ということで、何回か訪問しています。

無線LANルーター(1F) -(無線)- (2F)中継機 -(有線)- 各PC

という構成です。最初は中継機より先でエラー、有線・無線ともルーターに直接接続すると問題がなかったので、
中継機の故障と判断し交換、それからは異常を聞いていなかったので解決したと思っていたのですが…

数週間後、再発したと連絡が。ルーターに有線でつなぐと問題なし、無線でつなぐと…IPアドレスが取得できません。
ルーターを電源オフ→オンしても効果なし、試しにファームウェアを最新版に更新すると、復旧しました。
ただ、ファーム更新が効果あったのか、ルーター再起動の結果なのか、はっきりしないまま様子を見ていただくようお願いして退室します。

はたして結果は…ダメです。翌日、また再発したとの連絡が。
さっそく伺ってみると、やはり有線では問題なし、無線では接続はしてもIPアドレスが取得できません。
検証も兼ねて、中継機は元に戻し、ルーターの交換を提案します。

ルーター設置、PPPoE設定問題なし、旧のルーターはLAN側192.168.1.のセグメントでした。
新のルーターは初期設定が192.168.11.
のセグメントですので旧のルーターのセグメントに合わせて変更してやります。
設定変更、ルーター再起動…

インターネットにつながりません。

「WAN側IPアドレスとLAN側IPアドレスが競合しています」( ・`ω・´)

いやいやいやいやいやいや、そんなわけないでしょう、設定間違えたかな…
もう一度、飛んでしまったPPPoE設定からやり直します。

「WAN側IPアドレスとLAN側IPアドレスが競合しています」(・`ω´・ ●)

…なんでやねん。

今までと同じセグメントなのにいきなりエラーで弾かれてばかり。
宅内の接続はどうなっているのか、線をたどるとルーターの上流にはONUと思しきものが。狭い所にあってよく見えません。
ええい、じゃあ上流の線をPCに直結したらどんなIPが振られんねん、と試しに作業用のPCにケーブルを挿すと…

IPアドレス 192.168.1.105
デフォルトゲートウェイ 192.168.1.1

はい?さらに上流にDHCPがある?
つまり

上流機器(DHCPあり 192.168.1.1) - (WAN側192.168.1.*)無線LANルーター(LAN側192.168.1.1)

そら、無理だわ。

ルーターの内外で同じセグメント・サブネットマスクにしてしまうとルーターはどちらにパケットを送れば良いのか判断できません。
エラーが出たのは正しい動作だったわけです。

そこで旧のルーターに戻し、LAN側IPアドレスを192.168.11.*に変更しましたが、残念、症状が改善しません。

そこで新のルーターを初期設定の192.168.11.*のままで、LAN側の機器を設定変更し、様子を見ていただくようお願いして退室します。

おそらくルーターの上流にあったのはNTTのひかり電話ルーター、RT-500miと思われます。
この機種はDHCPサーバー機能を持つと同時にPPPoEブリッジができます。

ただ、分からないのが旧のルーターはそれでなぜ通信ができていたのか。セグメントを変更しても改善しなかったのはなぜ?
どうももやもやします。これで解決すればよいのですが…今回はすっきりしない結果となりました。