以前パソコンの初期設定で伺ったお客様からのご依頼です。
1週間ほど前からネットにつながらなくなってしまったとのこと。
機種はMicrosoftのSurface、Windows10です。

お伺いしてみてみると、無線LANのアイコンに「!」マークがついています。

ネット接続の状態を見るために、ネットワークと共有センターを開きます。
(無線LANのアイコンを右クリック→ネットワークと共有センターを開くを左クリック)

「識別されていないネットワーク」「ネットワークアクセスなし」になっています。

有線LANでも無線LANでも、ビックリマークがついてネットにつながらないとき、まずはIPアドレスが取れているかどうかの確認です。ほとんどの場合、LANに接続するとルーターからパソコンには「IPアドレス」という通信のための番号が割り振られますが、これがうまくいっていないと通信が正常にできません。ネットワークと共有センターの画面で「ワイヤレスネットワーク接続(優先の場合は「ローカルエリア接続」)」を左クリックします。

さらに「詳細」を左クリック。「ネットワーク接続の詳細」が開きます。
IPv4アドレスを確認すると、「192.168.〇.〇」になっているのが正しいのですが、「169.254.〇.〇」になっています。

「169.254.〇.〇」というのはルーターから番号をもらえなかったときに、パソコン自身が自分で決める番号です。自分で決めて自分でつけた番号で、ルーターと通信するためのルールにものっとっていませんので通信できません。

もう1台のパソコンはネットにつながっているとのことなので、IPv4アドレスを見ると192.168.0.〇になっていました。
surfaceのほうも試しに手動で設定してみます。
「ネットワーク接続の詳細」→閉じる
「ワイヤレスネットワーク接続の状態(有線の場合は「ローカルエリア接続の状態」)」→閉じる
「ネットワークと共有センター」→「アダプターの設定の変更」を左クリック

「ワイヤレスネットワーク接続(有線の場合は「ローカルエリア接続」)」を左ダブルクリックすると詳細画面が開きます。

さらに「プロパティ」を左クリックします。

「この接続は次の項目を使用します」欄の中の「インターネットプロトコル バージョン4(TCP/IPv4)を選択し、「プロパティ」を左クリックします。

IPアドレス自動取得からアドレスを指定する設定に変更します。一般家庭ではルーターは「192.168.X.1(Xは0,1,10,11,24のどれかであることが多いです)」です。「192.168.X.」までは同じ値になるようにして、「.」で区切られた4番目の数字を255より小さい適当な数字にします。ほかのパソコンなどと重複してはいけないので、大き目の数字にします。サブネットマスクは「255.255.255.0」、デフォルトゲートウェイはルーターのIPアドレス、優先DNSサーバーもルーターのIPアドレスです。

入力したら「OK」を左クリックで設定が反映されます。すると、

ビックリマークがなくなってインターネットにつながりました!

実はこの症状、Windows10では以前にも発生していました。その時も同じ方法で設定すると治り、そのあとは自動取得に戻しても大丈夫でした。ご依頼者様はSurfaceを外出先にも持ち歩いて無線LAN接続されるとのことですのでIPアドレス固定では都合が良くありません。そこで今回も自動取得に戻します。

またビックリマークがついてしまいました。確認するとIPアドレスが取れていません。むむむ・・・

何度かIPアドレス手動⇔自動や再起動を繰り返すも改善しません。どうしよう・・・かな、と考えて、
範囲を広げて再起動することにしました。

surfaceをIPアドレス自動取得に設定してシャットダウン、無線LANルーター(アクセスポイントモード)を電源オフ(=電源の線を抜きます)、さらに上流の有線ルーターも電源オフ(=電源の線を抜きます)して、10数えてから有線LANルーターを電源オン(=電源の線を挿します)、すこし待ってから無線LANルーター(アクセスポイントモード)も電源オン、またすこし待ってたらsurfaceの電源を入れると、

今度は自動でIPアドレスが取得できました。シャットダウン→起動を繰り返しても問題ありません。

これで問題解決です。しかしWindows10の弱点というか癖というか、改善する余地があるのかもしれません。